Redistribution-Controlling Route Feedback

Route Redistribution on multi-point always cause route feedback.. On this post i will discuss how to control route feedback and method in achieving stable routing table.

Current scenario

  • Redistribute OSPF route into EIGRP via R3
  • Redistribute EIGRP route into OSPF via R2
  • Redistribute RIP into EIGRP via R5

Traffic from R4 to R5 will use the path

R4->R2->R7->R1->R5

Traffic from R5 to R4 will use the path

R5->R1->R3->R4

Pre-Configured LAB in GNS3 Format

Route Redistribution Lab 2- Controlling Route Feedback LAB (GNS3 Format)

Initial Configuration

R1

hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 description R7 e0/0
 ip address 71.71.71.1 255.255.255.0
!
interface Ethernet0/1
 description R3 e0/1
 ip address 13.13.13.1 255.255.255.0
!
interface Ethernet0/2
 description R5 e0/2
 ip address 51.51.51.1 255.255.255.0
!
router eigrp 234
 network 1.1.1.1 0.0.0.0
 network 13.13.13.1 0.0.0.0
 network 51.51.51.1 0.0.0.0
 network 71.71.71.1 0.0.0.0
 no auto-summary
!
router rip
 version 2
 network 51.0.0.0
!

R2

hostname R2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/1
 description R7 e0/1
 ip address 72.72.72.2 255.255.255.0
!
interface Ethernet0/2
 description R4 e0/2
 ip address 24.24.24.2 255.255.255.0
!
router eigrp 234
 network 2.2.2.2 0.0.0.0
 network 72.72.72.2 0.0.0.0
 no auto-summary
!
router ospf 123
 redistribution eigrp 234 subnet
 network 24.24.24.2 0.0.0.0 area 0

R3

hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
 description R4 e0/0
 ip address 34.34.34.3 255.255.255.0
!
interface Ethernet0/1
 description R1 e0/1
 ip address 13.13.13.3 255.255.255.0
!
interface Ethernet0/2
 description R6 e0/2
 ip address 63.63.63.3 255.255.255.0
!
router eigrp 234
 redistribution ospf 123 metric 1 1 1 1 1
 network 13.13.13.3 0.0.0.0
 network 63.63.63.3 0.0.0.0
 no auto-summary
!
router ospf 123
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0

R4

hostname R4
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
 description R3 e0/0
 ip address 34.34.34.4 255.255.255.0
!
interface Ethernet0/2
 description R2 e0/2
 ip address 24.24.24.4 255.255.255.0
!
interface Ethernet0/3
 no ip address
 shutdown
!
router ospf 234
 network 4.4.4.4 0.0.0.0 area 0
 network 24.24.24.4 0.0.0.0 area 0
 network 34.34.34.4 0.0.0.0 area 0

R5

hostname R5
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Ethernet0/2
 description R2 e0/2
 ip address 51.51.51.5 255.255.255.0
!
router eigrp 234
 redistribute rip metric 1 1 1 1 1
 network 51.51.51.5 0.0.0.0
 no auto-summary
!
router rip
 version 2
 network 5.0.0.0

R6

hostname R6
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Ethernet0/2
 ip address 63.63.63.6 255.255.255.0
!
router eigrp 234
 network 51.51.51.5 0.0.0.0
 no auto-summary
!
router eigrp 234
 network 6.6.6.6 0.0.0.0
 network 63.63.63.6 0.0.0.0
 no auto-summary

R7

hostname R7
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.0
!
interface Ethernet0/0
 ip address 71.71.71.7 255.255.255.0
!
interface Ethernet0/1
 ip address 72.72.72.7 255.255.255.0
!
router eigrp 234
 network 51.51.51.5 0.0.0.0
 no auto-summary
!
router eigrp 234
 network 7.7.7.7 0.0.0.0
 network 71.71.71.7 0.0.0.0
 network 72.72.72.7 0.0.0.0
 no auto-summary

Without any changes on the initial configuration. We have the following ping and trace result.


R1


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/56/80 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/57/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/58/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/40 ms

R1#

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 1.1.1.1 4 msec 4 msec 0 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 71.71.71.7 44 msec 40 msec 40 msec
  2 72.72.72.2 80 msec 60 msec 44 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 13.13.13.3 60 msec 40 msec 40 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 13.13.13.3 40 msec 92 msec 60 msec
  2 34.34.34.4 80 msec 80 msec 80 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 51.51.51.5 40 msec
    13.13.13.3 44 msec
    51.51.51.5 40 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 13.13.13.3 44 msec 80 msec 80 msec
  2 63.63.63.6 60 msec 60 msec 76 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 71.71.71.7 40 msec 40 msec 40 msec

R2


{ping $x}

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/38/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/40/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
...
Success rate is 0 percent (0/3)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/83/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/24 ms

R2(tcl)#

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 72.72.72.7 20 msec 32 msec 20 msec
  2 71.71.71.1 32 msec 40 msec 20 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 2.2.2.2 4 msec 0 msec 4 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 24.24.24.4 12 msec 20 msec 20 msec
  2 34.34.34.3 32 msec 44 msec 36 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 24.24.24.4 28 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 72.72.72.7 24 msec 20 msec 20 msec
  2 71.71.71.1 20 msec 44 msec 20 msec
  3 13.13.13.3 40 msec 64 msec 56 msec
  4 34.34.34.4 40 msec 40 msec 40 msec
  5 24.24.24.2 80 msec 64 msec 60 msec
  6 72.72.72.7 60 msec 60 msec 60 msec
  7 71.71.71.1 60 msec 72 msec 100 msec
  8 13.13.13.3 104 msec 56 msec 84 msec
  9 34.34.34.4 80 msec 112 msec 80 msec
 10 24.24.24.2 80 msec 80 msec 112 msec
 11 72.72.72.7 148 msec 104 msec 100 msec
 12 71.71.71.1 100 msec 120 msec 112 msec
 13 13.13.13.3 144 msec 120 msec 152 msec
 14 34.34.34.4 120 msec 120 msec 120 msec
 15 24.24.24.2 124 msec 124 msec 116 msec
 16 72.72.72.7 164 msec 140 msec 180 msec
 17 71.71.71.1 144 msec 152 msec 152 msec
 18 13.13.13.3 180 msec 140 msec 160 msec
 19 34.34.34.4 192 msec 144 msec 192 msec
 20 24.24.24.2 188 msec 224 msec 160 msec
 21 72.72.72.7 204 msec 180 msec 184 msec
 22 71.71.71.1 192 msec 188 msec 192 msec
 23 13.13.13.3 204 msec 192 msec 212 msec
 24 34.34.34.4 204 msec 220 msec 180 msec
 25 24.24.24.2 204 msec 200 msec 212 msec
 26 72.72.72.7 244 msec 220 msec 224 msec
 27 71.71.71.1 252 msec 272 msec 272 msec
 28 13.13.13.3 332 msec 316 msec 292 msec
 29 34.34.34.4 304 msec 300 msec 304 msec
 30 24.24.24.2 324 msec 292 msec 324 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 72.72.72.7 36 msec 20 msec 20 msec
  2 71.71.71.1 40 msec 44 msec 36 msec
  3 13.13.13.3 60 msec 64 msec 52 msec
  4 63.63.63.6 88 msec 76 msec 72 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 72.72.72.7 24 msec 20 msec 24 msec
R2(tcl)#

R3


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/59/64 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/26/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/36/48 ms

R3(tcl)#

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 13.13.13.1 20 msec 20 msec 12 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 13.13.13.1 24 msec 12 msec 8 msec
  2 71.71.71.7 12 msec 28 msec 12 msec
  3 72.72.72.2 40 msec 44 msec 36 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 3.3.3.3 4 msec 0 msec 4 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 34.34.34.4 16 msec 16 msec 16 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 34.34.34.4 20 msec 16 msec 24 msec
  2 24.24.24.2 44 msec 40 msec 20 msec
  3 72.72.72.7 56 msec 40 msec 40 msec
  4 71.71.71.1 40 msec 40 msec 40 msec
  5 13.13.13.3 40 msec 40 msec 44 msec
  6 34.34.34.4 60 msec 64 msec 56 msec
  7 24.24.24.2 80 msec 64 msec 104 msec
  8 72.72.72.7 80 msec 84 msec 116 msec
  9 71.71.71.1 88 msec 80 msec 80 msec
 10 13.13.13.3 84 msec 80 msec 112 msec
 11 34.34.34.4 92 msec 104 msec 72 msec
 12 24.24.24.2 112 msec 120 msec 124 msec
 13 72.72.72.7 152 msec 116 msec 136 msec
 14 71.71.71.1 120 msec 112 msec 120 msec
 15 13.13.13.3 136 msec 156 msec 136 msec
 16 34.34.34.4 196 msec 144 msec 172 msec
 17 24.24.24.2 172 msec 200 msec 204 msec
 18 72.72.72.7 200 msec 200 msec 184 msec
 19 71.71.71.1 200 msec 204 msec 200 msec
 20 13.13.13.3 204 msec 200 msec 224 msec
 21 34.34.34.4 220 msec 224 msec 224 msec
 22 24.24.24.2 240 msec 232 msec 232 msec
 23 72.72.72.7 232 msec 284 msec 240 msec
 24 71.71.71.1 272 msec 264 msec 252 msec
 25 13.13.13.3 252 msec 252 msec 252 msec
 26 34.34.34.4 264 msec 260 msec 272 msec
 27 24.24.24.2 276 msec 300 msec 304 msec
 28 72.72.72.7 300 msec 304 msec 304 msec
 29 71.71.71.1 312 msec 272 msec 292 msec
 30 13.13.13.3 312 msec 304 msec 300 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 63.63.63.6 36 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 13.13.13.1 16 msec 20 msec 20 msec
  2 71.71.71.7 44 msec 40 msec 28 msec

R4


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/53/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/18/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/77/96 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/50/52 ms
R4(tcl)#foreach x {
+>(tcl)#1.1.1.1
+>(tcl)#2.2.2.2
+>(tcl)#3.3.3.3
+>(tcl)#4.4.4.4
+>(tcl)#5.5.5.5
+>(tcl)#6.6.6.6
+>(tcl)#7.7.7.7
+>(tcl)#} {traceroute $x}

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 24.24.24.2 24 msec 20 msec 20 msec
  2 72.72.72.7 32 msec 40 msec 80 msec
  3 71.71.71.1 40 msec 64 msec 48 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 24.24.24.2 28 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 34.34.34.3 16 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 4.4.4.4 4 msec 0 msec 4 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 24.24.24.2 8 msec 24 msec 16 msec
  2 72.72.72.7 52 msec 92 msec 48 msec
  3 71.71.71.1 52 msec 48 msec 52 msec
  4 13.13.13.3 52 msec 48 msec 52 msec
  5 34.34.34.4 52 msec 64 msec 48 msec
  6 24.24.24.2 72 msec 76 msec 64 msec
  7 72.72.72.7 104 msec 100 msec 100 msec
  8 71.71.71.1 104 msec 100 msec 104 msec
  9 13.13.13.3 96 msec 104 msec 100 msec
 10 34.34.34.4 100 msec 104 msec 96 msec
 11 24.24.24.2 124 msec 120 msec 120 msec
 12 72.72.72.7 152 msec 152 msec 160 msec
 13 71.71.71.1 156 msec 148 msec 144 msec
 14 13.13.13.3 168 msec 152 msec 112 msec
 15 34.34.34.4 132 msec 172 msec 168 msec
 16 24.24.24.2 172 msec 172 msec 172 msec
 17 72.72.72.7 184 msec 200 msec 200 msec
 18 71.71.71.1 236 msec 200 msec 200 msec
 19 13.13.13.3 204 msec 180 msec 212 msec
 20 34.34.34.4 200 msec 208 msec 196 msec
 21 24.24.24.2 224 msec 220 msec 224 msec
 22 72.72.72.7 232 msec 252 msec 252 msec
 23 71.71.71.1 264 msec 240 msec 264 msec
 24 13.13.13.3 252 msec 252 msec 252 msec
 25 34.34.34.4 252 msec 260 msec 252 msec
 26 24.24.24.2 272 msec 272 msec 272 msec
 27 72.72.72.7 304 msec 280 msec 244 msec
 28 71.71.71.1 292 msec 252 msec 292 msec
 29 13.13.13.3 300 msec 308 msec 300 msec
 30 34.34.34.4 312 msec 304 msec 240 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 24.24.24.2 40 msec 24 msec 24 msec
  2 72.72.72.7 40 msec 60 msec 40 msec
  3 71.71.71.1 20 msec 60 msec 20 msec
  4 13.13.13.3 40 msec 60 msec 20 msec
  5 63.63.63.6 76 msec 48 msec 92 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 24.24.24.2 12 msec 20 msec 24 msec
  2 72.72.72.7 48 msec 40 msec 40 msec
R4(tcl)#

R5


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/80/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/85/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/80/80 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/48/60 ms

R5#

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 51.51.51.1 60 msec 40 msec 40 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 51.51.51.1 40 msec 40 msec 40 msec
  2 71.71.71.7 60 msec 44 msec 40 msec
  3 72.72.72.2 40 msec 60 msec 80 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 51.51.51.1 12 msec 8 msec 12 msec
  2 13.13.13.3 8 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 51.51.51.1 20 msec 8 msec 12 msec
  2 13.13.13.3 40 msec 40 msec 20 msec
  3 34.34.34.4 60 msec 60 msec 40 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 5.5.5.5 4 msec 4 msec 0 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 51.51.51.1 40 msec 12 msec 8 msec
  2 13.13.13.3 20 msec 44 msec 40 msec
  3 63.63.63.6 40 msec 60 msec 40 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 51.51.51.1 16 msec 12 msec 20 msec
  2 71.71.71.7 28 msec 40 msec 24 msec
R5#

R6


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/64/80 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/89/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/92/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/100/120 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/76/80 ms
R6(tcl)#

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 63.63.63.3 36 msec 40 msec 40 msec
  2 13.13.13.1 60 msec 60 msec 60 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 63.63.63.3 40 msec 40 msec 40 msec
  2 13.13.13.1 60 msec 60 msec 60 msec
  3 71.71.71.7 80 msec 80 msec 80 msec
  4 72.72.72.2 72 msec 96 msec 76 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 63.63.63.3 40 msec 40 msec 40 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 63.63.63.3 40 msec 40 msec 40 msec
  2 34.34.34.4 80 msec 100 msec 80 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 63.63.63.3 40 msec 60 msec 40 msec
  2 34.34.34.4 80 msec 80 msec 72 msec
  3 24.24.24.2 76 msec 76 msec 76 msec
  4 72.72.72.7 56 msec 80 msec 56 msec
  5 71.71.71.1 76 msec 76 msec 76 msec
  6 51.51.51.5 72 msec 76 msec 92 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 6.6.6.6 4 msec 0 msec 0 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 63.63.63.3 44 msec 40 msec 40 msec
  2 13.13.13.1 60 msec 60 msec 40 msec
  3 71.71.71.7 80 msec 80 msec 60 msec
R6(tcl)#

R7


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/44/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/72/80 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/84/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R7(tcl)#

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 71.71.71.1 20 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 72.72.72.2 16 msec 20 msec 20 msec
Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 71.71.71.1 16 msec 20 msec 8 msec
  2 13.13.13.3 24 msec 28 msec 32 msec
Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 71.71.71.1 28 msec 20 msec 20 msec
  2 13.13.13.3 24 msec 16 msec 40 msec
  3 34.34.34.4 32 msec 40 msec 40 msec
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 71.71.71.1 20 msec 16 msec 40 msec
  2 51.51.51.5 40 msec 40 msec 40 msec
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 71.71.71.1 36 msec 40 msec 40 msec
  2 13.13.13.3 36 msec 16 msec 16 msec
  3 63.63.63.6 80 msec 64 msec 52 msec
Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 7.7.7.7 4 msec 0 msec 4 msec

With the result above we could see the pattern of the route loop which is cause by R3 wrong decision to choose OSPF path over EIGRP. To solve this issue we need to change the AD (Administrative Distance) on R3 for external EIGRP routes to ensure it will use EIGRP route over OSPF.


Solution 1 Manipulate R3 EIGRP AD

router eigrp 234
 distance eigrp 90 109 


Explanation for Solution 1:

If we trace the route of R5 loopback this is what is happening

– R5 loopback is redistributed from RIP into EIGRP which make the R5 loopback an external route on the EIGRP domain increases the AD into 170.

– R5 Loopback route now an external EIGRP route will be redistributed along with the rest of EIGRP route into R2 OSPF domain which make all the EIGRP route (Internal and External) to be E2 route on the OSPF domain, All has an AD of 110.

– As the route propagated from R4 (OSPF) toward R3, R3 now has two set of route from EIGRP and OSPF domain and by the rules of AD EIGRP internal route will be install on the Routing table of R3 except for the R5 External route which has a lower AD from the OSPF domain (110 vs 170).

– As R3 redistributed OSPF route to the EIGRP domain. All OSPF route will be propagated including the External EIGRP route of R5 loopback.

– Internal EIGRP route that has been redistributed into the OSPF would not be back to the EIGRP domain since on R3, those route has been choosen from the EIGRP domain instead of OSPF.

– From R3 route are propagated to R1, now R1 has two path for the R5 loopback via R3 and toward R5 and since both has same metric (EIGRP) it would forward on both path and this is where the loop occur.

– So the solution work by ensuring that R3 choose R5 looback route from the EIGRP domain instead from OSPF domain and cancelling the advertisement of another path toward R1 from R3 when redistributing the OSPF route.


Solution 2 Use Route Tagging/Filtering Method on R5/R2/R3 and make the metric of R5 better over R3 redistributed routes


Router R2
router ospf 123
 redistribute eigrp 234 subnets route-map e2o
!
route-map e2o permit 10
 match tag 120
 set tag 120
!
route-map e2o permit 20
 set tag 110

Router R3
router eigrp 234
 redistribute ospf 123 metric 1 1 1 1 1 route-map oe2

route-map oe2 deny 10
 match tag 110
!
route-map oe2 permit 20
description all other tag

Router R5
router eigrp 234
! Change metric to ensure rip has the best path
 redistribute rip metric 100 1 255 1 1500 route-map r2e
!
route-map r2e permit 10
 set tag 120


Explanation for Solution 2:

This has same route propagation except that we are tagging every route on the distribution point.

– On R5 we tag the RIP route (Tag 120) and provided a better metric.
– On R2 we tag the EIGRP route with 110 and matching RIP tag to be retag with same tag 120
– On R3 we filter Tag 110 (EIGRP redistributed Route) so it will not be advertise toward EIGRP Domain.
– So on R1 since R5 redistributed rip has better metric than the redistributed ospf, it will choose the correct path.


Route Redistribution Lab 2 – Controlling Route Feedback
Tagged on:                         

Leave a Reply

%d bloggers like this: